Daha önce hiç bir şey sorun yok iken yaklaşık 10 gün önce bloğumdaki herhangi bir yazıyı Google+ profilimde paylaşmak istediğimde yukarıdaki resimdeki gibi, paylaştığım içerikte Türkçe karakter sorunu oluyordu. Önce, sorunun benden yani wordpressteki herhangi bir dosyadan kaynaklandığını düşündüm ve 4 – 5 gün boyunca neredeyse bütün kodları tek tek kontrol ettim. Kodlar içinde eksik bir şey mi var diye, fakat kodlarda veya diğer dosyalarda herhangi bir sorun yoktu.

 Sonra aklıma kullandığım cache eklentisi geldi, acaba cache eklentisinden kaynaklanabilir mi diye düşündüm ve kullandığım Wp fastast cache eklentisini pasif hale getirdiğimde sorun düzeliyordu, eklentiyi tekrar aktif hale getirdiğimde sorun yine ortaya çıkıyordu. Artık, yaşadığım Türkçe Karakter sorununun kullandığım Wp Fastest Cache eklentisinden kaynaklandığını biliyordum. Bu arada şunu bir kez daha belirtmek istiyorum blog sitemdeki yazılarımda herhangi bir sorun yoktu, sorun sadece Google+ paylaşımlarında ortaya çıkıyordu. Konuyu biraz araştırayım dedim ve konuyla ilgili hiç bir bilgi bulamadım.  Sadece Google forumlarında Nalan Ünal hanım efendi sorunla ilgili bir konu açmıştı Nalan hanımın açtığı konuyu buradan görebilirsiniz.

Google formlarındaki konuyu okuduğumda sorunun sadece bende olmadığını gördüm ve açıkçası biraz rahatladım çünkü bu kadar kişi bu sorunu yaşıyorsa demek ki benden kaynaklanan bir sorun değil diye düşündüm.  Nalan hanım program yapımcısı Emre Vona ile bağlantıya geçip sorunun düzeltildiğini söyledi. Bunun üzerine bende Emre bey ile irtibata geçtim ve sorunu bildirdim. Eklentiyi kurarken bir şeyi eksik yapmamızdan dolayı böyle bir sorun oluşuyordu. Emre bey sağ olsun bir resim gönderdi ve ne yapmam gerektiğini resimde gösterdi. Eğer sizde eklentiyi kullanıyorsanız ve böyle bir sorun yaşıyorsanız aşağıdaki resim gösterilen bölüme gelip resimdeki gibi web/snippet user-agent’ı hariç tutarsanız aşağıdaki resimdeki gibi yaptığınızda sorunun çözüldüğünü göreceksiniz.

Google+ Paylaşımlarında Türkçe Karakter Sorununu Çözmek İçin Yapılması Gerekenler

1. WordPress admin panelinde  Wp Fastest Cache eklentisinde Hariç bölümünü açın.

2. Exclude User-Agents bölümünde Add New Rule butonuna tıklayın. Açılan pencerede aşağıdaki resimde kırmızı ile gösterdiğim kutucuk içine benim yazdığım  gibi web/snippet yazın ve save butonuna tıklayarak kaydedin.

Sorunun düzeldiğini göreceksiniz. Yapılması gereken ayar sadece bunlar. Ben yaptım düzeldi, eminim ki sizlerde bu şekilde yaptığınızda düzelecektir. Eğer sorun yinede düzelmiyorsa eklenti yapımcı Emre bey ile iletişime geçmenizi tavsiye ederim. Önce Nalan hanıma sonrasında yardımlarını esirgemeyen eklenti yapımcısı Emre bey‘e teşekkürlerimi sunuyorum.

ABONE OLARAK YENİ YAZILARDAN HABERDAR OLABİLİRSİNİZ.

Abone Olduğunuz İçin Teşekkür Ederim.

Bir Şeyler Yanlış Gitti, Lütfen Tekrar Deneyin